Browsers

December 9, 2013

Reminder – Internet Explorer versions 9 and 10 are NOT supported for use in OmniUpdate.
You may see blank screens or other issues.

We suggest using Firefox or Chrome, if you’re having IE issues.

For more info on OU Browsers: http://support.omniupdate.com/oucampus9/support/troubleshooting/supported-browsers.html

Currently the following browsers are supported:
Browser Versions
Microsoft Internet Explorer 8, 9
Mozilla Firefox 23, 24, 25
Google Chrome 29, 30, 31
Apple Safari 6.0.x, 6.1, 7.0

Internet Explorer 10 and 11 are not yet certified for use with OU Campus. IE10 will be certified for use with OU Campus v10 when it is released.